修复M1 芯片的Mac设备

前些天从公司采购了M1芯片的Macbook Pro,到手后发现系统初始化设置时被设置了Remote Management,等于系统镜像被出厂时预设成公司的企业设备管理了。而我是用来做开发测试用的,被Remote Management不方便,需要移除该管理。

咨询公司IT后,他们先把我的设备序列号从Apple Business Manager中移除掉。

如图

此时,如果通过长按电源键进入Recovery后重新安装Big Sur,安装完毕重启初始化时,还会出现Remote Management。

从苹果官方找到如下文档,在另一台mac电脑上利用Apple Configurator 2,通过Type-c将该电脑与需要修复的电脑连接,需要修复的电脑这边需要将Type-c插入离屏幕近的这个口。https://support.apple.com/zh-cn/guide/apple-configurator-2/apdd5f3c75ad/mac

然后打开Apple Configurator 2, 需要修复的电脑保持关机。然后同时按下电源,左Option,左Ctrl,右Shift,保持10秒,松开三个按键继续按住电源键7秒。松开电源键。然后稍等几秒,Apple Configurator 2里,该需要修复的电脑就进入DFU模式了,此时选择设备,右键,高级,修复。漫长的等待之后,就修复完了。重启,我用电脑创建了一个Big Sur最新版的启动U盘,长按电源键进入启动选项,选择启动U盘,安装Big Sur。完成重启后,Remote Management就不见了。

Aquantia万兆网卡在Windows下几乎没有上传速度

好久没玩Fifaonline4了,今天国庆节前的周日,公司放假,在iMac Pro的Bootcamp Windows10里装了游戏,准备玩几局,结果游戏比赛中每局都会弹出网络错误,然后游戏就断了。按说我这联通千兆宽带,再怎么差也不至于网络不好到每局都断开吧,于是找了游戏客服,客服给了一个网络检查工具,看起来就是检查延时的。也都是几毫秒到几十毫秒之内。看不出什么问题。

闲着没事用Speedtest测了一下速,发现了问题,下载测速能够达到800多M(光猫桥接主路由有一点损耗),但是上传居然只有0.04M,估计这样就是时不时网络上传就断了,所以游戏里才会弹出网络错误。

RSC为Enabled时测速

由于我用的是iMac Pro自带的Aquantia 万兆以太网口,怀疑是不是因为Bootcamp的驱动有问题,就试了下用Wifi连接网络,发现Wifi虽然因为无线路由有点落后而导致下载速度降到了400M左右,但是上传能稳定在北京联通的上限30M左右。

看来是这个有线网卡的问题,就在网上搜了搜AQUANTIA万兆网卡的问题,发现有华硕论坛里也提到了Aquantia万兆网卡的上传问题,还有Intel万兆网卡的问题,继续搜索,发现了macrumors论坛里有人提到了Aquantia万兆网卡在Mac Pro上Bootcamp时的上传问题。我这是iMac Pro,应该也差不多。

帖子里提到,要去网卡属性的高级属性里,将RSC(Recv Segment Coalescing) IPv4 和IPv6 从默认的Enabled改成Disabled。

设置成功后,再次Speedtest测速,一切正常,进入游戏也没有再发生网络错误。

RSC为Disabled时测速

macOS里的Microsoft Edge浏览器错误代码6

昨天更新macOS10.15.6到Safari14.0以后,发现Microsoft Edge浏览器不能使用了,打开后就显示错误代码6.

错误代码6

并且右上角会挨个弹出所安装的插件不能使用。

查找微软社区里有相关问题反馈 https://answers.microsoft.com/zh-hans/microsoftedge/forum/all/macos-10156-microsoft/bd885458-7566-47db-b223-e758d7135a39?rtAction=1600425417892&tm=1600425432912

有人提到了重启macOS可以解决问题,尝试重启系统后发现问题暂时解决。

所以Safari更新为什么会导致Edge不能用呢?